Formlabs forum login issues
Incident Report for Formlabs
Resolved
Formlabs Forum login is fully functional
Posted Mar 22, 2024 - 11:35 UTC
Update
We identified the issue and working on a fix.
Posted Mar 22, 2024 - 09:38 UTC
Monitoring
Users cannot log in into Formlabs Forum.
Posted Mar 20, 2024 - 09:37 UTC
This incident affected: Formlabs.com Website.