AWS Service Degradation Impacting Dashboard Operations

Incident Report for Formlabs

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 07:07 UTC

Update

The AWS outage has been resolved, and both the dashboard and group queues are now fully operational. Please note that some job processing tasks may have failed during the outage and will not be retried automatically. These jobs will need to be reuploaded to the group queues for processing.
Posted Oct 21, 2025 - 07:07 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 19:41 UTC

Monitoring

AWS services have recovered, and our systems are now returning to normal operation slowly. We are currently investigating options to mitigate any lost print actions that occurred during the outage.
Posted Oct 20, 2025 - 19:39 UTC

Investigating

Due to a service degradation affecting AWS, our dashboard is currently unable to start or monitor the status of slicing jobs for printers. Our team is actively monitoring system health and working to mitigate any residual issues. The dashboard service is expected to recover once the AWS outage is resolved.
Posted Oct 20, 2025 - 14:47 UTC
This incident affected: Dashboard and Printer connectivity.