Connection issues
Incident Report for Formlabs
Resolved
Network connection error was resolved
Posted Apr 08, 2024 - 07:30 UTC
Investigating
We are investigating connection issues with Dashboard and Fleet Control
Posted Apr 08, 2024 - 07:18 UTC
This incident affected: Dashboard and Printer connectivity.