Delays in emails and printers going offline
Incident Report for Formlabs
Resolved
The incident has been resolved. Some email and sms notifications from today are lost, we are sorry any inconvenience caused.
Posted Mar 01, 2024 - 20:21 UTC
Update
Despite our best efforts some email were lost. We are sorry about that.

Emails will experience some delay for the next couple hours but normal operation should resume soon.
Posted Mar 01, 2024 - 18:08 UTC
Update
Printer connectivity is restored.
Posted Mar 01, 2024 - 17:47 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 01, 2024 - 15:37 UTC
Update
Some printers are currently offline, causing delayed remote prints and Fleet Control jobs not being picked up. We are working on reducing the load in the system and printers should come back online.
Posted Mar 01, 2024 - 15:29 UTC
Update
The queue is clearing out slowly, you may experience some slowness on the website. We are working on speeding up the rollout of the missed notifications.
Posted Mar 01, 2024 - 12:45 UTC
Monitoring
Our task queue overfilled, causing delays in sent emails and texts. We adjusted the queue's settings and monitoring the situation.
Posted Mar 01, 2024 - 07:00 UTC
This incident affected: Dashboard and Printer connectivity.